Echo in my Headset/Bluetooth

Hi, I’ve often found that when I use a headphone or Bluetooth from my PC to give a presentation, even if the participant is connected through the PC or mobile, I keep listening back to my voice very distinctly. Once I tried, reconnecting it got resolved. Next time it did not. It’s not only very embarrassing but also time consuming to disconnect & reconnect, especially when I’ve to give the presentation to a new person or a group of new persons. In situations, it’s a matter of trust building & we can not to lose because of any such minor issues.

There are two sources of the echo.

  • local
  • remote

This is when your voice goes out, mixed by the server, sent to participants, their mic picks it up and sends back to the server and eventually it comes back to you so you hear it.

Your voice is not even leaving your computer, it bounced back inside of the drivers/OS and played back to you.

Typically the “Local” has almost no delay while “Remote” has noticeable delay like 200ms+ and is very annoying as it feels like you are interrupting yourself. Another difference is that “local” only affects you but “remote” affects everyone besides the “bad guy”. Also the “local” echo is almost perfect while “remote” is typically somewhat distorted/garbled.

If you have a “Local” echo - this is most likely the problem with your hardware or OS.
If you have a “remote” echo - it is not even the problem of your computer or the server - it is a problem on the “far end” aka “the bad guy”.

“Local” is a rare problem so I am assuming that you have a “remote” problem.
To troubleshoot it you need to find the “bad guy” (i.e. the person who causes the echo). You can pay attention to the active speaker indicator and if you see someone “speaking” while he/she should not - this means they are causing the echo into the conference. You need to ask them to go on mute or mute them yourself.

Hope it helps.

Thanks, @etcipnja for such a detailed reply. :grinning: Probably it’s the “bad guy” because of which this problem occurs. It’s not always but only with a few individual participants. I generally give online presentations in 1-o-1 settings. The issue is when I’m in a 1-o-1 situation, it’s expected by two of us to talk or get some vocal feedback. How can I expect them to be on mute? In a group meeting, it may not be difficult as all are muted by me & I can unmute each participant individually as and when required.

I think muting a participant who is a potential business client is not the right solution. Is there any other solution? Can I give some solution to the “bad guy” so that we have a smooth conversation & presentation?

Warm regards,

Rahul Dev


If we agreed that the problem is remote then nothing you can do on your end. Switching or reconnecting devices on your end would not change what remote user sends into the meeting.

We do have echo cancellation algorithm that works on every client, but this algorithm possibly fails if:

  • user is in the room with high reverberation
  • user has excessively loud speakers
  • user has mic in one device while speakers is in the other device (example: mic is in the USB web camera, speakers are external via the amplifier)
  • there are number of other more or less crazy scenarios that can cause echo

How to mitigate it (use one or combination)

  • The easiest way is to ask participants to use headphones
  • Turn their speakers volume down
  • Try to use integrated mic and speakers (Jabra 510 is a great example)
  • mute self if not speaking

Thank you,