Joining from the Web Browser


Greetings! :grinning::bouquet:

Today my one prospect wanted to join the FCC meeting from the web browser as his device has restrictions to install any new app. He doesn’t have enough admin rights to do so. When he tried to access the FCC meeting from the browser, he was asked to download the app. When I tried to access the meeting from the web from my system, I was asked to allow to open the preinstalled app. There was no option to access the meeting from the browser. I get many such instances where the prospects cannot install the FCC app on their device.

I am sharing the screenshot of my system.

As you can see, there is no option to continue from the web. It was there till a year back. When I press the cancel button & press the join button again, the same window pops out.

Can you please suggest how to access an FCC meeting from the web?

Warm regards,

Rahul Dev


If user already has application installed we run the application (your case)

If first time user tries to join a meeting - we do recommend to download and install the application, but we also offer a fallback to the browser (see the screenshot below). Sorry I have huge resolution so font may look small.

You as a host may tweak the join link so you force your participant to use the browser client.